lkml.org 
[lkml]   [2011]   [Nov]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: SDHCI regression since 2.6.39
On Wed, Sep 14, 2011 at 12:54:08PM -0700, Jeremy Fitzhardinge wrote:

Ok. Thread is a bit dated but the bug is the same by the looks of it.
Apologies to anyone hit by the funk of a thousand years. :)

> On 09/14/2011 11:38 AM, Chris Ball wrote:
> > It could indeed be some kind of signal integrity issue. The easy way to
> > investigate that would be to boot Windows and see if it works there, and
> > the hard way would be to find a friendly hardware hacker with a nice scope.
>
> I have the original HDD with Windows on it around here somewhere; when I
> get the chance I'll switch them around and see what Windows thinks of it
> (I guess if its still failing then its a warranty fix).

I have an X220 with the same issue. Using a MicroSDHC card with an adapter.

Windows likes it, Linux does not. Very similar looking errors as what Jeremy
has.

Linux: 3.1
BIOS: 1.21 (08/02/2011)
OS: Debian Wheezy

SanDisk adapter with Kingston 4GB MicroSDHC card.

I could help with any testing.

--
"A search of his car uncovered pornography, a homemade sex aid, women's
stockings and a Jack Russell terrier."
- http://www.dailytelegraph.com.au/news/wacky/indeed/story-e6frev20-1111118083480


\
 
 \ /
  Last update: 2011-11-03 13:57    [W:0.047 / U:67.908 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site