[lkml]   [2009]   [May]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH 3/3a] ptrace: add _ptrace_may_access()
On Wed, May 06, 2009 at 01:32:24PM -0700, Roland McGrath wrote:
> > Something like the patch below allows the reuse of the locked
> > version of __ptrace_may_access and pushes the int->bool conversion
> > into an inline.
> I think it would be cleaner and safe/simple enough to invert the public
> ptrace_may_access() to just return the int and invert the ! on all the
> callers (all one in fs/proc/task_mmu.c and all four in fs/proc/base.c).

Yeah. And at the same time we might move it out of ptrace.c and give it
a more descriptive name given that most users aren't related to ptrace
in any way. may_inspect_task maybe? I'm good at naming things..

 \ /
  Last update: 2009-05-06 22:51    [W:0.090 / U:0.568 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site