lkml.org 
[lkml]   [2009]   [May]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH][mmtom] clean up once printk routine
Hi!

> Yes. There are also some places to be able to use printk_once().
> Are there any place I missed ?
>
> == CUT HERE ==
>
> There are some places to be able to use printk_once instead of hard coding.
>
> It will help code readability and maintenance.
> This patch doesn't change function's behavior.
>
> Signed-off-by: Minchan Kim <minchan.kim@gmail.com>
> CC: Dominik Brodowski <linux@dominikbrodowski.net>
> CC: David S. Miller <davem@davemloft.net>
> CC: Ingo Molnar <mingo@elte.hu>
> ---
> arch/x86/kernel/cpu/common.c | 8 ++------
> drivers/net/3c515.c | 7 ++-----
> drivers/pcmcia/pcmcia_ioctl.c | 9 +++------
> 3 files changed, 7 insertions(+), 17 deletions(-)
>
> diff --git a/arch/x86/kernel/cpu/common.c b/arch/x86/kernel/cpu/common.c
> index 82bec86..dc0f694 100644
> --- a/arch/x86/kernel/cpu/common.c
> +++ b/arch/x86/kernel/cpu/common.c
> @@ -496,13 +496,9 @@ static void __cpuinit get_cpu_vendor(struct cpuinfo_x86 *c)
> }
> }
>
> - if (!printed) {
> - printed++;
> - printk(KERN_ERR
> + printk_once(KERN_ERR
> "CPU: vendor_id '%s' unknown, using generic init.\n", v);
> -
> - printk(KERN_ERR "CPU: Your system may be unstable.\n");
> - }
> + printk_once(KERN_ERR "CPU: Your system may be unstable.\n");
>

You should delete the variable, right?

Plus, the code now uses two variables instead of one.

Pavel
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html


\
 
 \ /
  Last update: 2009-05-26 10:39    [W:0.024 / U:1.068 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site