lkml.org 
[lkml]   [2009]   [Dec]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[PATCH] DRM: Rename clamp variable
DRM: Rename clamp variable

linux/kernel.h has a "clamp" macro, but r300_cmdbuf also uses a variable
with the same name. Right now it doesn't seem to include the header,
but sooner or later someone will. So better rename the variable
now.

Signed-off-by: Andi Kleen <ak@linux.intel.com>

---
drivers/gpu/drm/radeon/r300_cmdbuf.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Index: linux-2.6.33-rc1-ak/drivers/gpu/drm/radeon/r300_cmdbuf.c
===================================================================
--- linux-2.6.33-rc1-ak.orig/drivers/gpu/drm/radeon/r300_cmdbuf.c
+++ linux-2.6.33-rc1-ak/drivers/gpu/drm/radeon/r300_cmdbuf.c
@@ -990,7 +990,7 @@ static inline int r300_emit_r500fp(drm_r
int sz;
int addr;
int type;
- int clamp;
+ int isclamp;
int stride;
RING_LOCALS;

@@ -999,10 +999,10 @@ static inline int r300_emit_r500fp(drm_r
addr = ((header.r500fp.adrhi_flags & 1) << 8) | header.r500fp.adrlo;

type = !!(header.r500fp.adrhi_flags & R500FP_CONSTANT_TYPE);
- clamp = !!(header.r500fp.adrhi_flags & R500FP_CONSTANT_CLAMP);
+ isclamp = !!(header.r500fp.adrhi_flags & R500FP_CONSTANT_CLAMP);

addr |= (type << 16);
- addr |= (clamp << 17);
+ addr |= (isclamp << 17);

stride = type ? 4 : 6;


\
 
 \ /
  Last update: 2009-12-21 02:27    [W:0.987 / U:0.868 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site