lkml.org 
[lkml]   [2009]   [Nov]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC,PATCH 14/14] utrace core
Hi -

On Tue, Nov 24, 2009 at 10:26:19PM +0100, Andi Kleen wrote:
> [...]
> > For example. tracehook_report_syscall_entry() has a lot of callers
> > in arch/, each callsite should be changed to do
> >
> > if ((task_utrace_flags(current) & UTRACE_EVENT(SYSCALL_ENTRY)) &&
> > utrace_report_syscall_entry(regs))
> > ret = -1; // this depends on machine
> >
> > instead of simply calling tracehook_report_syscall_entry().
>
> That should be in the utrace code?
>
> I don't have a problem with having common code somewhere,
> just not a whole layer whose only purpose seems to be obfuscation.

One man's obfuscation is another man's abstraction.
Would you be satisfied if "tracehook_" was renamed "utracehook_"?


- FChE


\
 
 \ /
  Last update: 2009-11-24 22:33    [from the cache]
©2003-2011 Jasper Spaans