lkml.org 
[lkml]   [2009]   [Jan]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectsupport of touchscreen reported as eGalax but is not working
Hi

I recently got a used USB touchscreen and try to get it working
It looks like a eGalax type but not really is :-(

I am using kernel 2.6.28.2 but also tried the one that comes with
fedora 10 (2.6.27) When I connect the touchscreen dmesg shows

usb 2-1: new low speed USB device using uhci_hcd and address 13
usb 2-1: string descriptor 0 read error: -32
usb 2-1: string descriptor 0 read error: -32
usb 2-1: configuration #1 chosen from 1 choice
usb 2-1: string descriptor 0 read error: -32
generic-usb: probe of 0003:0EEF:0001.000B failed with error -32
usb 2-1: New USB device found, idVendor=0eef, idProduct=0001
usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0

lsusb -vv for the device gives

Bus 002 Device 013: ID 0eef:0001 D-WAV Scientific Co., Ltd eGalax
TouchScreen Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 1.10
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 8
idVendor 0x0eef D-WAV Scientific Co., Ltd
idProduct 0x0001 eGalax TouchScreen
bcdDevice 1.00
iManufacturer 1
iProduct 2
iSerial 0
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 34
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 4
bmAttributes 0xa0
(Bus Powered)
Remote Wakeup
MaxPower 44mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 3 Human Interface Device
bInterfaceSubClass 0 No Subclass
bInterfaceProtocol 0 None
iInterface 0
HID Device Descriptor:
bLength 9
bDescriptorType 33
bcdHID 1.12
bCountryCode 0 Not supported
bNumDescriptors 1
bDescriptorType 34 Report
wDescriptorLength 141
Report Descriptors:
** UNAVAILABLE **
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0008 1x 8 bytes
bInterval 5

/proc/bus/usb/devices gives

T: Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 13 Spd=1.5 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0eef ProdID=0001 Rev= 1.00
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr= 44mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=00 Prot=00 Driver=usbhid
E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=5ms

I compared this output to other eGalax and discovered some differences
like that iManufactur and iProduct is not filled also
bInterfaceSubClass and bInterfaceProtocol

The kernel is not installing any input device for the touchscreen
so /proc/bus/input/devices does not show the touchscreen

To check if the thing is actually working I did a quick test on XP
and there it works.

Any chance to get this thing working?
I can test any patch maybe required and provide more information if
needed. If am wrong on this mailing list please tell me where
I should post this question.

Thanks for any help

Max
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2009-01-25 23:51    [from the cache]
©2003-2011 Jasper Spaans