lkml.org 
[lkml]   [2008]   [Nov]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] rcupdate: move synchronize_sched() back to rcupdate.c V2
On Mon, Nov 10, 2008 at 11:22:15AM +0800, Lai Jiangshan wrote:
> Paul E. McKenney wrote:
> > On Thu, Nov 06, 2008 at 02:47:44PM +0800, Lai Jiangshan wrote:
> >> this fix remove ugly macro, and increase readability for rcupdate codes
> >>
> >> changed from v1:
> >> use HAVE_SPECIAL_RCU_BH/SCHED instead of define duplicate version of
> >> synchronize_sched().
> >
> > Hello, Jiangshan!
> >
> > I very much like getting rid of the ugly macro. I of course like the
> > kernel-doc fixes. ;-)
> >
> > I am not yet convinced of the HAVE_SPECIAL_RCU_BH and
> > HAVE_SPECIAL_RCU_SCHED pieces. It is not clear to me that this approach
> > is simpler than the current approach of simply providing the appropriate
> > definitions for the symbols in the implementation-specific rcuxxx.h
> > file.
> >
> > Am I missing something?
> >
> > Thanx, Paul
> >
>
> I think:
>
> RCU_BH is not required, we can used RCU instead. so HAVE_SPECIAL_RCU_BH
> will help for implementation which has not RCU_BH.
>
> HAVE_SPECIAL_RCU_SCHED is a little different, RCU and RCU_SCHED are both
> required for the kernel. But I think, in an implementation,
> if rcu_read_lock_sched() implies rcu_read_lock(), we may not need implement
> RCU_SCHED too(sometimes we may implement RCU_SCHED for performance).
> so HAVE_SPECIAL_RCU_SCHED will help.

If I understand correctly, this is the "old way":

------------------------------------------------------------------------

rcupdate.h:

#define rcu_read_lock_bh() __rcu_read_lock_bh()
#define rcu_read_unlock_bh() __rcu_read_unlock_bh()

rcupreempt.h:

#define __rcu_read_lock_bh() { rcu_read_lock(); local_bh_disable(); }
#define __rcu_read_unlock_bh() { local_bh_enable(); rcu_read_unlock(); }

------------------------------------------------------------------------

And then this is the "new way":

------------------------------------------------------------------------

rcupdate.h:

#ifdef HAVE_SPECIAL_RCU_BH
#define rcu_read_lock_bh() __rcu_read_lock_bh()
#define rcu_read_unlock_bh() __rcu_read_unlock_bh()
#else
#define __rcu_read_lock_bh() { rcu_read_lock(); local_bh_disable(); }
#define __rcu_read_unlock_bh() { local_bh_enable(); rcu_read_unlock(); }
#endif /* HAVE_SPECIAL_RCU_BH */

rcupreempt.h:

#define HAVE_SPECIAL_RCU_BH

------------------------------------------------------------------------

If we had ten different RCU implementations, then the "new way" would save
a little bit of code. But the "old way" is a bit easier to figure out.

So I am in favor of getting rid of the ugly macro, and also in favor
of fixing the kerneldoc, but opposed to the HAVE_SPECIAL_RCU_BH and
HAVE_SPECIAL_RCU_SCHED changes.

Or am I missing something?

Thanx, Paul


\
 
 \ /
  Last update: 2008-11-10 19:47    [W:0.079 / U:0.304 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site