[lkml]   [2008]   [Nov]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] rcupdate: move synchronize_sched() back to rcupdate.c V2
Paul E. McKenney wrote:
> On Thu, Nov 06, 2008 at 02:47:44PM +0800, Lai Jiangshan wrote:
>> this fix remove ugly macro, and increase readability for rcupdate codes
>> changed from v1:
>> use HAVE_SPECIAL_RCU_BH/SCHED instead of define duplicate version of
>> synchronize_sched().
> Hello, Jiangshan!
> I very much like getting rid of the ugly macro. I of course like the
> kernel-doc fixes. ;-)
> I am not yet convinced of the HAVE_SPECIAL_RCU_BH and
> HAVE_SPECIAL_RCU_SCHED pieces. It is not clear to me that this approach
> is simpler than the current approach of simply providing the appropriate
> definitions for the symbols in the implementation-specific rcuxxx.h
> file.
> Am I missing something?
> Thanx, Paul

I think:

RCU_BH is not required, we can used RCU instead. so HAVE_SPECIAL_RCU_BH
will help for implementation which has not RCU_BH.

HAVE_SPECIAL_RCU_SCHED is a little different, RCU and RCU_SCHED are both
required for the kernel. But I think, in an implementation,
if rcu_read_lock_sched() implies rcu_read_lock(), we may not need implement
RCU_SCHED too(sometimes we may implement RCU_SCHED for performance).

Thanx, Lai.

 \ /
  Last update: 2008-11-10 04:29    [W:0.132 / U:0.104 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site