lkml.org 
[lkml]   [2005]   [Nov]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [linux-usb-devel] Re: /dev/sr0 not ready, but working
Date
El Martes, 22 de Noviembre de 2005 12:56, Alan Stern escribió:
> On Tue, 22 Nov 2005, Gustavo Guillermo Pérez wrote:
> > Yes, I do the same operations as iee1394 and USB, and here we go:
> > 1) ieee1394 Dirty DVD+RW ad UdfFileSystem without pktcdvd cause +rw
> > No Real problems, the errors on logical sectors was and old bad mount,
> > but the second one writing 5 o 6 MB of a lot of small files does not
> > produce the error.
> > 2) ieee1394 Normal growisofs -Z /dev/sr0 -J -r /folder
> > No errors on the media, writing as iso not packet.
> > The error appears while writing the DVD+RW 96 times, not the same udf
> > disk. 3) Reading from The writed disc
> > No error, normal operation.
> > 4)Changing to USB Interface and ShutDown the iee1394, and do the udf
> > Stuff. Normal operation no errors on the DVD-RW media.
> > 5) USB Writing Normal growisofs -Z /dev/sr0 -J -r /folder
> > No errors on the media, writing as iso not packet.
> > The error appears while writing the DVD-RW 57 times, not the same udf
> > disk, less data less errors.
> > 6) Reading data from USB Interface.
> > No errors normal operation.
> > 7) lspci, lsusb
> > The mouse is not relevant, I was plugged today.
> >
> > Working with +RW -RW -R and +R, allways writing not udf packets the error
> > appears. As IDE interface the drive does not produce any device not ready
> > error.
>
> I know practically nothing about how your device works, so this is just a
> guess. It seems likely that the IEEE1394-USB/ATA interface controller
> translates the commands it receives over the external bus into a sequence
> of ATA or ATAPI commands that is somewhat different from the sequence of
> commands Linux would use if the drive were directly attached to an IDE
> controller. As a result, perhaps the drive sends those "not ready"
> replies when you use it over an external bus but not when you use attach
> it over ATA.
>
> Or maybe not... Maybe the drive _does_ send those "not ready" messages
> and the IDE driver ignores them instead of printing them in the system
> log. Or perhaps those messages are sent by the bus interface controller
> and not by the drive itself. I just don't know.
>
> Alan Stern
Ok, yes may be the drive sends some command bad back translated to the system.
And may be is not important, cause drive works, and media almost never get
badwritten.

--
Gustavo Guillermo Pérez
Compunauta uLinux
www.compunauta.com
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-11-23 03:24    [W:0.050 / U:3.540 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site