lkml.org 
[lkml]   [2003]   [Aug]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectFw: [Cooker] usb audio detection problem
Date


>
>
> > After a week of fighting with my new M-Audio USB Quattro device I have solved
> > a problem with our hardwared detection.
> > I used the standard alsa configuration lines in /etc/modules.conf, i.e.
> > alias sound-slot-0 snd-usb-audio
> > above snd-usb-audio snd-pcm-oss
> > but when restarting alsa, the OSS driver was loading first (module name
> > 'audio'), and then the alsa driver was unable to access the PCM stream. By
> > adding 'audio' to /etc/hotplug/blacklist, everything worked fine.
> > Is there some way to fix this permanently?
> > Is everyone else with usb-based audio currently forced to use OSS when
> > Mandrake's default should be alsa?
>
> both audio and snd-usb-audio modules have exactly the same matching
> criteria (in your case) and "audio" appears first in /lib/modules/`uname -r`/modules.usbmap so it wins.
>
> I guess so far the ony "official" way is to blacklist it.

If having two modules with the same matching ids is expected,
what is normal way to prefer one of them? The problem currently
is system-wide usbmap is consulted first so there is actually
no way to override it.

This is under 2.4.21.

TIA

-andrey
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.049 / U:1.428 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site