lkml.org 
[lkml]   [2003]   [Jun]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectHyperThreading not working under 2.4.21
Date
Hello there,

I recently tried to upgrade to the 2.4.21 vanilla kernel. I am using a Pentium
IV 3,06ghz HT. Amongst other things, I enabled the following options:
"Pentium-4 processor Family, SMP support, ACPI support". I tried it with both
ACPI support on and off. I can join a copy of my .config if it is required.

Anyway, when booting the 2.4.21 kernel my second logical processor
is not detected at all. All works as if I had only one processor. There is no
error message. A cat /proc/cpuinfo reports only one cpu.

This problem only occurs with 2.4.21 kernel. My HT processor was working
perfectly with any branch of the 2.4.20 serie (I was using 2.4.20-ck6). My
second logical processor was perfectly recognized. Thus, it does not seem to
be a problem with bios or mb settings.

A "very" quick search through google made me conclude that this problem had
not been reported yet so please, forgive me if you are all already aware of
such a problem.

Best regards,

R.C


P.S: join a copy to my e-mail adress if you may.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:36    [W:0.026 / U:4.224 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site