lkml.org 
[lkml]   [2002]   [Mar]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectsomething's wrong with the ps/2 mouse driver (or devfs error?)
Hi!

Sometimes the gpm segfaults I don't know why. Now X dropped the
mouse control too. Here is the log which gpm wrote:

Mar 3 22:41:46 binky /usr/sbin/gpm[194]: oops() invoked from gpm.c(182)
Mar 3 22:41:46 binky /usr/sbin/gpm[194]: /dev/psaux: No such device or address
Mar 3 22:43:30 binky /usr/sbin/gpm[10837]: oops() invoked from gpm.c(993)
Mar 3 22:43:30 binky /usr/sbin/gpm[10837]: /dev/psaux: No such device or address
Mar 3 22:46:27 binky /usr/sbin/gpm[10862]: PS/2 mouse failed init
Mar 3 22:46:27 binky /usr/sbin/gpm[10862]: oops() invoked from gpm.c(1019)
Mar 3 22:46:27 binky /usr/sbin/gpm[10862]: mouse initialization failed: Inappropriate ioctl for device

The 3rd try to start gpm was successful. After I quit X and
restart didn't started:

(**) Option "Device" "/dev/input/mice"
(EE) xf86OpenSerial: Cannot open device /dev/input/mice
No such file or directory.
(EE) Generic Mouse: cannot open input device
(EE) PreInit failed for input device "Generic Mouse"
(II) UnloadModule: "mouse"
(WW) No core pointer registered
No core pointer

In ~20 sec I've tried to start X again and it works now. The gpm
did segfault earlier too but X did't drop the control over the mouse.

binky:~# uname -a
Linux binky 2.4.19-pre2-ac1 #1 Sat Mar 2 04:28:17 CET 2002 i686 unknown
binky:~# gpm -v
gpm 1.19.6, Thu Oct 4 00:21:21 CEST 2001

There is devfs in the kernel but is not mounted.

--
Woockie
..."what is there in this world that makes living worthwhile?"
Death thought about it. "CATS," he said eventually, "CATS ARE NICE."
(Terry Pratchett, Sourcery)

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:24    [W:0.025 / U:1.796 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site