lkml.org 
[lkml]   [2002]   [Dec]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectMTRR refusing to be configured
    Hi,

    I'm running kernel 2.5.51 on a Pentium III Katmai processor, stepping 3,
    and I've been trying to properly setup the MTRR registers on it for this
    PCI graphics card. However this has been an unsuccessful quest so far. I
    do have CONFIG_MTRR turned on and obviously there's the `mtrr' flag on
    /proc/cpuinfo. Taking the base address and the memsize for the card, I've
    tried to do a simple:

    # echo "base=0xd8000000 size=0x2000000 type=write-combining" >| /proc/mtrr

    However the kernel complains with:

    ubik kernel: mtrr: illegal type: "write-combining"

    This happens for every other type I choose, be it write-back,
    uncachable, well, whatever. Considering this works just fine under a 2.4
    kernel (worked on 2.4.19 to be more precise) it's mostly weird that it
    doesn't do the same on 2.5.

    Oh, I'd appreciate if anyone replying would CC me. Thanks in advance.

    Best regards,

    Paulo Andre'

    --
    That's the difference between me and the rest of the world! Happiness isn't
    good enough for me! I demand euphoria! -- Calvin
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:31    [W:0.020 / U:1.408 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site