lkml.org 
[lkml]   [2001]   [Jul]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRE: Trouble Booting Linux PPC 2000 On Mac G4
Date
From
I think what we are seeing is XBoot rather than yaboot and we tried just
about all conceivable "kernel options", as exposed by Xboot. When Xboot
comes up it shows a ramdisk_size=8192 as the only default parameter.
Rapidly growing to hate the non-intuitive nature of the MAC OS we are
not experts on the Mac OS. P.S. We are running Mac OS 9.1.

Oops, We just discovered that Xboot does not work with MacOS 9.1 (geez)
.... you MUST use yaboot.


We will try the Q4 release.

Thanks,
Tim


-----Original Message-----
From: Jeffrey W. Baker [mailto:jwbaker@acm.org]
Sent: Friday, July 06, 2001 4:09 PM
To: Tim McDaniel
Cc: linux-ppc@vger.kernel.org; linux-kernel@vger.kernel.org
Subject: RE: Trouble Booting Linux PPC On Mac G4 2000




On Fri, 6 Jul 2001, Tim McDaniel wrote:

>
> We are having a great degree of difficulty getting Linux PPC20000
> running on a Mac G4 466 tower with 128MB of memory, One 30MB HD and
one
> CR RW. This is not a NuBus based system. To the best of our knowledge
we
> have followed the user manual to the tee, and even tried forcing video
> settings at the Xboot screen.
>
>
> But still, when we encounter the screen where you must chose between
> MacOS and Linux and we chose linux, the screen goes black and for all
> practical purposes the box appears to be locked. We've also tried
> editing yaboot.conf but can't seem to save the new file.
>
> Any help would be greatly appreatiated.

add "video=ofonly" to your boot command line. That is, at the yaboot
"boot: " prompt, type "linux video=ofonly"

If that doesn't work, try something else :)

-jwb

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:56    [W:0.358 / U:0.008 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site