lkml.org 
[lkml]   [2001]   [Jun]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectbad file descriptor
Hello all,
i am facing a problem on my Red Hat Linux 6.2 machine. When i
boot in my Linux box it boot properly till it reaches the stage
where it says "Press I for interactive setup"
From there it starts giving me errors like this : -
Mounting proc file system dup2 : Bad File Descriptor [FAILED]
Configuring kernel parameters dup2 : Bad File Descriptor [FAILED]
Loading default keymap/etc/rc.d/rc.sysinit : /dev/null : read only
file system
Activating swap partition dup2 : Bad File Descriptor [FAILED]
Seting hostname localhost.localdomain : Bad File Descriptor [FAILED]
Checking root filesystem : Bad File Descriptor [FAILED]

An error occured during file system check
For maintance mode give password [ctrl-d for normal setup]


when I give root password i can log in as single user and it gives
this message the moment I log in:

bash: /dev/null :Read only file system
kcd : cannot create file /root/.kcd.newdir
Broken pipe.

When i press ctrl-D for normal login the machine reboots.
I tried running fsck, e2fsck, checked for bad blocks and made force
checking too. still the problem is not solved.
This system was running perfectly for 6-7 months.
Please help.
thanks in advance and waiting for the reply.
--
Best regards,
shantanu mailto:shantanu@mail.vu


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:55    [W:0.019 / U:0.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site