lkml.org 
[lkml]   [2001]   [Apr]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectReiserFS oops/panic/uninterruptable sleeps in -ac
I have an SMP PenIII that had been running 2.4.1-ac18 for 65
days. Its /home partition was a newly created (first used on
that kernel) ResierFS 3.6.x partition. For no obvious reason,
two days ago, processes started going into uninterruptable
sleeps, reportedly in "down" in the kernel.

We rebooted into 2.4.3-ac14, and suddenly we had oops and
eventually panics when accessing certain parts of /home.
(just an "ls" could spawn an oops, and an "ls -l" could
spawn a panic). This is a production box, so unfortunately
writing down the oops/panic info was the lowest priority
on my list and it didn't happen.

We tried a reiserfsck with the newest reiserfsutils with
both --rebuild-sb and --rebuild-tree, and neither worked.

Finally, as a last resort before returning to ext2, we tried
2.4.3 stock kernel. Magically, everything worked fine.
We have yet to see any instability, and we can't make any
processes stick, even under load.

This seems to be a bug somewhere in the ac patch, possibly
related to SMP. If anyone could figure it out, it'd really
be nice to fix this before the bug makes it way into the
stock kernels.

Ian Gulliver
Penguin Hosting
http://www.penguinhosting.net/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:52    [W:0.031 / U:3.144 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site