lkml.org 
[lkml]   [2001]   [Jan]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: 2.4.0-prerelease IDE CD-ROM problem


OK, mystery (partially) solved. I have the Gnome CD Player applet running in my
panel. (Yeah, I know, if I'm running Gnome, I deserve whatever I get. :-)
Anyway, the CD player can be added to the panel in two forms: a launcher that
just launches the application window, and an applet that has controls which
allow a CD to be played directly from the panel without opening a window. I
recently switched from the first to the second variety. It turns out that this
applet apparently grabs the device as soon as a CD is inserted (to identify the
CD and, if necessary, go out on the Internet to find it in the CDDB database).
It doesn't prevent a data CD from being mounted or unmounted, but in the most
recent kernels, it _does_ prevent the CD drive tray from being unlocked after
it's unmounted The only way to open the drive is to hit the "Eject" control on
the applet itself. When I tried this yesterday, it hung and required a reboot
every time. However, the new (Jan 4) version of prelease-diff fixed this so
that the eject control works. Without this applet running, the CD drive behaves
normally.

BTW, this isn't just a ThinkPad issue; my homebuilt Pentium MMX tower exhibits
the same behavior.


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:52    [W:0.023 / U:0.032 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site