lkml.org 
[lkml]   [2000]   [Feb]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectIDE weird behavior in 2.3.41 w/ synchronous FTP reception

    Hello,

    I'm facing a problem in FTP reception problem with a new synchronous card
    driver (the Cyclades-PC300 driver), but I've just found out something at
    least interesting.

    If I do FTP _transmissions_ , no problems happen.

    If I do FTP _receptions_ , at high speeds (e.g. 4Mbps) and using big files
    (e.g. 10MB) the system crashes hard, with an oops report that's evidently
    corrupted:

    Unable to handle kernel paging request at virtual address 0d841801
    printing eip:
    0d841801
    *pde = 00000000
    Oops: 0000
    CPU: 0
    EIP: 0010:[<0d841801>]
    EFLAGS: 00010286
    eax: 00000009 ebx: c289c048 ecx: 00000001 edx: 00000000
    esi: c28173e0 edi: c2816bbc ebp: 00000000 esp: c027bed0
    ds: 0018 es: 0018 ss: 0018
    Process swapper (pid: 0, stackpage=c027b000)
    Stack: d4ae2b59 c90e0f7d 1bde679c 27c3302c eaf3f1b9 9fcc90be 21aa8c63
    238d6b20
    87823b9e 5742b078 8f534e42 2252c054 67c34420 a0ad1633 9e6388da
    f285c016
    04c120da e1f2d7c2 88cbed94 14fdf40f e9d9dacd 2fee179e 4f91e7b0
    a4174c2a
    Call Trace:
    Code: <1>Unable to handle kernel paging request at virtual address
    0d841801
    printing eip:
    c010bb3a
    *pde = 00000000


    The stack has really weird values, and no call / code trace is reported.


    Now, the interesting part: if I do FTP receptions _but_ I redirect the
    incoming file to /dev/null (i.e., I don't write the file to the IDE HD,
    just receive it through the line and save it as /dev/null), no crashes
    happen whatsoever !!!

    Also, if I replace the IDE HD by a SCSI HD, running in the same system, no
    crashes happen whatsoever.

    I've tested this in both a P166 / 32MB RAM and in a Dual PII-400 / 128MB
    RAM. In the Dual PII, the problem takes longer to happen, but nevertheless
    it does happen.

    Furthermore, I tested it in kernels 2.2.14 / 2.2.15pre5, and the problem
    does NOT happen. It happens in kernels 2.3.40 / 2.3.40pre4 / 2.3.41.

    Again:
    - The problem does not happen in the latest 2.2.x kernels.
    - The problem _always_ happens when the IDE HD is used and the file from
    the FTP reception transfer is written to the HD.
    - The problem _never_ happens when the IDE HD is used and the file from
    the FTP reception transfer is written to /dev/null.
    - The problem _never_ happens when the SCSI HD is used in any test
    scenario (i.e., writing or not to the HD).

    Can anybody give some suggestions on where I should look at in order to
    try and solve this problem?? Any help would be highly apreciated. If you
    need to look at the PC300 driver source code, please let me know and I can
    send it to you.

    TIA and Regards,
    Ivan


    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:56    [W:0.030 / U:59.676 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site