lkml.org 
[lkml]   [2000]   [Dec]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.2.17 + ide patches + 61gb ibm disc = problem
On Tue, 5 Dec 2000, Robert B. Easter wrote:

> > Uniform Multi-Platform E-IDE driver Revision: 6.30
> > ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
> > PIIX4: IDE controller on PCI bus 00 dev 21
> > PIIX4: chipset revision 1
> > PIIX4: not 100% native mode: will probe irqs later
> > ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda:pio, hdb:DMA
> > ide1: BM-DMA at 0xd808-0xd80f, BIOS settings: hdc:pio, hdd:DMA
> > hdb: IBM-DTLA-307060, ATA DISK drive
> > hdd: IBM-DTLA-307060, ATA DISK drive
> > ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
> > ide1 at 0x170-0x177,0x376 on irq 15
> > hdb: IBM-DTLA-307060, 58644MB w/1916kB Cache, CHS=7476/255/63, UDMA(33)
> > hdd: IBM-DTLA-307060, 58644MB w/1916kB Cache, CHS=119150/16/63, UDMA(33)

You have the classic BIOS issue it only works half way.
pass the geometries to fix one side of the other.

> > hdd1 [events: 00000001](write) hdd1's sb offset: 60051456
> > hdb1 [events: 00000001](write) hdb1's sb offset: 60050816
> >
>
>
> I don't understand why you have set them to be slaves when they are the only
> drives on the ports. Shouldn't you be setting the jumpers on both drives
> into the Single Drive (default) settings? I always thought the Master and
> Slave positions are to be used only when connecting two drives on one port.
>
> hda and hdc should be the devices.

This is true, what are you running in this bizzare mode?

Andre Hedrick
CTO Timpanogas Research Group
EVP Linux Development, TRG
Linux ATA Development

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:51    [from the cache]
©2003-2011 Jasper Spaans