lkml.org 
[lkml]   [2000]   [Nov]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Linux-2.2.x-BUG(?) memmory not detected

On Mon, 13 Nov 2000 01:43:44 Anton Altaparmakov wrote:
> Hi,
>
> Just noticed that both 2.2.18pre21 and RedHat-7.0-patched-2.2.16 kernels
> only detect 64Mb out of 192Mb RAM on my Dual Celeron/Intel 440GX chipset
> based workstation. - I haven't tried any other 2.2 kernels on that
> particular PC so maybe this is a general 2.2.x thing.
>
> The setup is one 64Mb SDRAM and one 128Mb SDRAM so it would seem that the
> 128Mb one is not detected at all.
>
> All 2.3/2.4 kernels I have tried have always detected the full 192Mb RAM.
>

It's a bug, but in the mobo. Some motherboards lie about its installed ram.
2.3+ kernels have a workaround for detection, but in 2.2 you still have
to manually add <append="mem=128M"> in your lilo.conf file.

--
Juan Antonio Magallon Lacarta #> cd /pub
mailto:jamagallon@able.es #> more beer

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:45    [W:0.029 / U:2.268 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site