lkml.org 
[lkml]   [2000]   [Oct]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.4.0-test9 kernel problems (was 2.4 kernel problems on 386)
I had problems loading a variant of this kernel on a 386. The problems
are now more obvious, as I've tried to operate this kernel, compiled for
a 386, on my pentium pro.

In this case, the kernel starts up, but has no communication with the
screen. No messages are logged to the screen. However, the messages are
logged to the disk. A message : Cannot find map file, and also :
Warning: unable to open an initial console. appear on the log, I can
forward more detail to anyone who is interested.

When I run the kernel on a 386, as far as I can tell, the machine just
plain halts and does nothing. If the kernel is compiled using gcc version
2.95.2, then it reboots on a 386. On the Pentium Pro, the behaviour is
the same.

Seems a bit odd that what would be a standard patch seems to be causing
this problem. Could be that a file or device is expected on the filesystem,
but it is not obvious from the logs.

There could indeed be a triple fault, as a previous participant suggested -
but I would not know. Getting the kernel to at least print on my pentium
pro would be a start.

Any ideas ?

I'm not on the list, so please copy me in correspondence.

Thanks,

--
John August

Some of us are paying for sins we have committed.
Others are paying for sins we still have to commit.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:39    [W:0.074 / U:1.220 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site