[lkml]   [1997]   [Feb]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: IRQ 2,9
On Tue, 11 Feb 1997, Charlie Ross wrote:

> I recently tried to add a new card to my computer, and needed an IRQ...
> heres what happened:
> anyway.. as you can see I'mm preety well full and out of irq's except for 2
> and 9... which I think are video related...
> The thing I am adding NEEDS to be on irq 12 (ps2 style mouse port) so I
> seed to move ms scsi card... it can only take 9,10,11 or 12 if i move it to
> 9 linux cant find it... which is wierd... B/C win95 can.
> I get the following errors:
> Feb 11 22:40:26 spiff linux: aha152x0: vital data: PORTBASE=0x340, IRQ=9,
> SCSI ID=7, reconnect=enabled, parity=enabled, synchronous=disabled,
> delay=100, extended translation=disabled
> Feb 11 22:40:26 spiff linux: aha152x: trying software interrupt, lost.
> Feb 11 22:40:27 spiff linux: aha152x: IRQ 9 possibly wrong. Please verify.
> Feb 11 22:40:27 spiff linux: scsi0 : Adaptec 152x SCSI driver; $Revision:
> 1.7 $
> Feb 11 22:40:27 spiff linux: scsi : 1 host.
> Feb 11 22:40:27 spiff linux: scsi : detected total.
> i tried moving my net card to 2 (the only other IRQ i was unsure of) and
> then moving my SCSI card to 11.... so NOTHING was on 9.... then when I
> rebooted linux it began to scream bloody murder about somthing on IRQ 9
> (yep 9 not a typo) the message was "Interupt 9: unknown device!" repeated
> forever. (or somthing to that effect... I was unable to do a copy/paste of
> it bc my system was unusable in that state)

I dont run scsi but my network card used to be on irq 2 which linux
translated to irq 9 and it all worked fine. I needed to jumper the
ethernet card to irq 2 and set its adr in rc.module (its an ne1000).
If if missed the irq jumper I got looping "...Interupt..." messages
very similar to yours but fixing the jumper solved it.

As I recall irq 2 is the cascade interrupt. The interrupts chips (?)
handle them in sets of 8 so 2 of these give you 16 interrupts but
it costs an interrupt to link them together and irq 2 is it... it
links the first 8 to the second 8 and the 'contact point' if you will,
on the second 8, is irq 9. Thats why linux sees the irq 9 when you
specify irq 2. My only thought is to see if a jumper might be off as
mine was. :-)

John Heil
South Coast Software
1-714-774-6952 or 1-714-774-6755

 \ /
  Last update: 2005-03-22 13:38    [W:0.032 / U:0.656 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site