lkml.org 
[lkml]   [1996]   [Jun]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectSubject: DEC tulip on EB164 alpha

I'm having trouble getting an SMC EtherPower 100 card recognized under
kernels from 1.3.57 to pre2.0.11. Under the older kernels (57 to be
specific, and I think 89 exibited this, also) and the de4x5 driver, the
hardware address is wrong -- I was able to ping out, but the only thing
that would respond was a Cabletron hub -- the Cisco router and the other
Linux hosts couldn't reply. So I moved up to newer kernels (89 and 90),
but they tend to lock when accessing eth0 under the tulip driver. I once
even got a message something to the effect of 'avoiding a deadlock'
(sorry, I know that's not very descriptive, but it was really late here
when I got that).

I've been tinkering with both the de4x5 driver and the tulip mainly from
2.0.11. The de4x5 driver thinks the card is running at 100Mb (it's not --
it's only on a 10Mb hub), as a result the lights on the hub go solid and
the rest of the machines on the hub go crazy trying to transmit.

The tulip driver locks right after the "ALCOR machine check" message.
When doing an ifconfig. I compiled arch/alpha/kernel/alcor.c with DEBUG
defined, and that's the only message I get. No additional debugging
messages appear after this.

I'd really like to get networking going, so if anyone can point me in the
right direction, I'd appreciate it. I've seen the de4x5 driver compiled
into commercial kernel images, so that's why I've been working with that
drivers, while I have an SMC EtherPower 10 in my Pentium that's been very
happy with the tulip driver. I'm not sure which to look into, so if
anyone could shed some light there, it would help.

Thanks,
Andrew

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Andrew Anderson http://amelia.db.erau.edu/~andrew/
Computer Support Specialist andrew@db.erau.edu
I don't speak for ERAU, and God knows I don't want them to speak for me!

Don't ask me, I'm just a burning duck.



=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Andrew Anderson http://amelia.db.erau.edu/~andrew/
Computer Support Specialist andrew@db.erau.edu
I don't speak for ERAU, and God knows I don't want them to speak for me!

Don't ask me, I'm just a burning duck.



\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.033 / U:2.816 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site