lkml.org 
[lkml]   [1996]   [Jun]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Why RedHat distribution.
David Sundqvist wrote:
>
> On Thu, 20 Jun 1996, hab wrote:
> > Every time I run rpm -i xxx.xxx.rpm (it returns can't find
> > ....packages.rpm. Try installing in a clean root directory.
>
> Hm, yes. There is a /var/lib/rpm/packages.rpm... it looks like it might
> be a file created by rpm after the installs... maybe try creating it with
> touch?

I tried all the convential things like touch or cat > .. but it seems to be
some type of binary format. It magically appears some time during installation
I haven't been able to pin down where or when. Thus my complaint about the
custom binary init which is different in the installation image than what
we have at run time. No I couldn't find any of the conventional inittabs,
rc files or linuxrc that we find in the running system in the installation
immages. I isolated to a custom init by finding out what the kernel first looks
for after booting, and then checking the man for init. Thus this question
and the followon one about the custom init.

> > No. Kernel recognizes vfat but every time I run the file configuration
> > manager it changes all my vfat entries in fstab to msdos. I've been
> > running 2.0 since the day of its release.
>
> Ah, oki :) I'm a control/commandline freak so I do my fstab manually.
> However, I looked through the fstool, and it looks trivial to modify for
> vfat support... It's written in tcl.
>

Really, just a nit poking fun at RedHats claim that only 11 packages need to
be updated for Linux 2.0.0

> > A script I could read and determine what I had to set up to get things to
> > work. A binary I can't. By The Way I figured out how to get to work but
> > It Tain't easy if your hardware does't match their Idea's for
> > configuration.
>
> Hm, you *are* talking about the init scripts in /etc/rc.d, right? Or have
> I misunderstood? The SysVInit control panel just shuffles links to the
> scripts in /etc/rc.d/init.d/ and the scripts are modifiable... If that's
> what you meant :).

See the answer above. I am specifically talking about the custom init on
the installation images that is replaced once everything is installed

>
> > Have you ever tried to install one of their packages into a non- Red Hat
> > distribution. It keeps asking for packages.rpm at least in rpm 2.0 and
> > above.
>
> Nope :) I reinstalled clean :).

What I am leading up to here is when somebody asks. I found the GCC ...
package but it ends in .rpm How can I use it. You would be tempted to
say get rpm.gz from ftp.redhat.com :/pub/.../I386/.... or one of its mirrors.
But if needs something else that isn't a valid answer. Most of the things I've
outlined wouldn't have been noticed if my install had gone flawlessly. But
my laptop required different PCMCIA modules than provided by redhat, and my
Desktop has swap on a scsi drive but root on an ide drive. These would be
good questions on a RedHat mailist but I thought I followed their subscription
instructions to the letter yet still no responses
>
> I hope this helped you some.
>
> Best regards,
> David
>
> David Sundqvist | So pound the nails in tight eyes screaming out of sight
> | against a grainlike curtain unbearably alive
> azzie@tellutec.se | heaven or hell whats the difference one to believe in one
> w-mute on irc | to live in...

Really, I hope to be a RedHat advocate, BB UU TT !!

Hubert Bahr


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.032 / U:0.068 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site