lkml.org 
[lkml]   [1996]   [Apr]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectAdaptec 2940UW Woes... part II
Date
From
I'm back off spring break now and back at work slamming my head into
a brick wall trying to figure out my problems with Adaptec's 2940UW
PCI controller.

My specs:

AHA2940UW rev. B, BIOS rev. 1.21, chipset AIC-7881U rev. 0
Adapter ID: 7, channel 0
Linux 1.3.84, aic7xxx driver version 2.24

The problems I'm encountering:

After any attempt to access the DEC DSP5300 disk at id 0,
the system will hang solid with the IDE driver giving messages
about interrupt requests { DriveReady SeekComplete }. After
lockup, the IDE hard disk LED is on constantly, so it seems
that there is some interference between the SCSI bus and the
IDE driver... The system is apparently not processing interrupts,
either, because CTRL-ALT-SCRLK doesn't give me a register
dump.

The solution:

I don't know, but I'm gonna give FreeBSD a whirl on this machine
to see if the support is any better. If so, I may look into
merging the code bases of the two drivers to try to fix the problem.

--
Corey D. Brenner -- (brenner@umr.edu,brenner@cs.umr.edu)
========================================================================
#include <std_disclaimer.h> | Right-wing, Libertarian, Redneck,
| Fascist, Racist, Bigoted, Homophobic,
This .signature is in | Sexist, Neo-Nazi, Militia-member,
>>>FEEL-AROUND<<< | [insert "conservative" synonym here],
| wacko at large. ;)
========================================================================
"I yam Popeye of Borg. You will be askimilgrated."


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.034 / U:22.708 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site