lkml.org 
[lkml]   [2024]   [Apr]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v1 3/3] thermal/debugfs: Rename thermal_debug_update_temp() to thermal_debug_update_trip_stats()
From


On 4/17/24 14:11, Rafael J. Wysocki wrote:
> From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
>
> Rename thermal_debug_update_temp() to thermal_debug_update_trip_stats()
> which is a better match for the purpose of the function.
>
> No functional impact.
>
> Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
> ---
> drivers/thermal/thermal_core.c | 2 +-
> drivers/thermal/thermal_debugfs.c | 2 +-
> drivers/thermal/thermal_debugfs.h | 4 ++--
> 3 files changed, 4 insertions(+), 4 deletions(-)
>
> Index: linux-pm/drivers/thermal/thermal_core.c
> ===================================================================
> --- linux-pm.orig/drivers/thermal/thermal_core.c
> +++ linux-pm/drivers/thermal/thermal_core.c
> @@ -504,7 +504,7 @@ void __thermal_zone_device_update(struct
> if (governor->manage)
> governor->manage(tz);
>
> - thermal_debug_update_temp(tz);
> + thermal_debug_update_trip_stats(tz);
>
> monitor_thermal_zone(tz);
> }
> Index: linux-pm/drivers/thermal/thermal_debugfs.c
> ===================================================================
> --- linux-pm.orig/drivers/thermal/thermal_debugfs.c
> +++ linux-pm/drivers/thermal/thermal_debugfs.c
> @@ -676,7 +676,7 @@ out:
> mutex_unlock(&thermal_dbg->lock);
> }
>
> -void thermal_debug_update_temp(struct thermal_zone_device *tz)
> +void thermal_debug_update_trip_stats(struct thermal_zone_device *tz)
> {
> struct thermal_debugfs *thermal_dbg = tz->debugfs;
> struct tz_debugfs *tz_dbg;
> Index: linux-pm/drivers/thermal/thermal_debugfs.h
> ===================================================================
> --- linux-pm.orig/drivers/thermal/thermal_debugfs.h
> +++ linux-pm/drivers/thermal/thermal_debugfs.h
> @@ -11,7 +11,7 @@ void thermal_debug_tz_trip_up(struct the
> const struct thermal_trip *trip);
> void thermal_debug_tz_trip_down(struct thermal_zone_device *tz,
> const struct thermal_trip *trip);
> -void thermal_debug_update_temp(struct thermal_zone_device *tz);
> +void thermal_debug_update_trip_stats(struct thermal_zone_device *tz);
> #else
> static inline void thermal_debug_init(void) {}
> static inline void thermal_debug_cdev_add(struct thermal_cooling_device *cdev) {}
> @@ -24,5 +24,5 @@ static inline void thermal_debug_tz_trip
> const struct thermal_trip *trip) {};
> static inline void thermal_debug_tz_trip_down(struct thermal_zone_device *tz,
> const struct thermal_trip *trip) {}
> -static inline void thermal_debug_update_temp(struct thermal_zone_device *tz) {}
> +static inline void thermal_debug_update_trip_stats(struct thermal_zone_device *tz) {}
> #endif /* CONFIG_THERMAL_DEBUGFS */
>
>
>

Reviewed-by: Lukasz Luba <lukasz.luba@arm.com>

\
 
 \ /
  Last update: 2024-04-22 13:15    [W:0.088 / U:0.580 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site