lkml.org 
[lkml]   [2024]   [Apr]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] hv/vmbus_drv: rename hv_acpi_init() to vmbus_init()
Date
As the driver now supports both ACPI and DeviceTree,
rename hv_acpi_init() to vmbus_init() and
change comments accordingly.

Signed-off-by: Erni Sri Satya Vennela <ernis@linux.microsoft.com>
---
drivers/hv/vmbus_drv.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
index 12a707ab73f8..e140cbf8d4c7 100644
--- a/drivers/hv/vmbus_drv.c
+++ b/drivers/hv/vmbus_drv.c
@@ -2609,7 +2609,7 @@ static struct syscore_ops hv_synic_syscore_ops = {
.resume = hv_synic_resume,
};

-static int __init hv_acpi_init(void)
+static int __init vmbus_init(void)
{
int ret;

@@ -2620,7 +2620,7 @@ static int __init hv_acpi_init(void)
return 0;

/*
- * Get ACPI resources first.
+ * Get VMBus resources first.
*/
ret = platform_driver_register(&vmbus_platform_driver);
if (ret)
@@ -2707,5 +2707,5 @@ static void __exit vmbus_exit(void)
MODULE_LICENSE("GPL");
MODULE_DESCRIPTION("Microsoft Hyper-V VMBus Driver");

-subsys_initcall(hv_acpi_init);
+subsys_initcall(vmbus_init);
module_exit(vmbus_exit);
--
2.34.1

\
 
 \ /
  Last update: 2024-05-27 16:46    [W:0.115 / U:0.168 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site