lkml.org 
[lkml]   [2023]   [Mar]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/8] serial: Core cleanups
Date
Serial core cleanups.

Ilpo Järvinen (8):
serial: Use ARRAY_SIZE() with iso7816 reserved array
serial: Use B0 instead of implicit zero assumption
serial: Remove extern from func prototypes in headers
serial: Move uart_change_speed() earlier
serial: Rename uart_change_speed() to uart_change_line_settings()
serial: Make hw_stopped bool
serial: Rename hw_stopped to old_hw_stopped & improve logic
serial: Remove uart_wait_until_sent() forward declaration

drivers/tty/serial/serial_core.c | 113 +++++++++++++++----------------
include/linux/serial_8250.h | 41 +++++------
include/linux/serial_core.h | 15 ++--
3 files changed, 80 insertions(+), 89 deletions(-)

--
2.30.2

\
 
 \ /
  Last update: 2023-03-27 00:51    [W:0.064 / U:0.620 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site