lkml.org 
[lkml]   [2017]   [Aug]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 0/3] livepatch: Introduce force sysfs attribute
On Fri, 11 Aug 2017, Josh Poimboeuf wrote:

> On Thu, Aug 10, 2017 at 12:48:12PM +0200, Miroslav Benes wrote:
> > Now there is a sysfs attribute called "force", which provides two
> > functionalities, "signal" and "force" (previously "unmark"). I haven't
> > managed to come up with better names. Proposals are welcome. On the
> > other hand I do not mind it much.
>
> Now "force" has two meanings, which is a little confusing. What do you
> think about just having two separate write-only sysfs flags?
>
> echo 1 > /sys/kernel/livepatch/signal
> echo 1 > /sys/kernel/livepatch/force
>
> That way there's no ambiguity.

Sure, why not. Moreover it would simplify things (no need for dummy 1/3
patch and its code).

Thanks,
Miroslav

\
 
 \ /
  Last update: 2017-08-14 10:50    [W:0.116 / U:0.748 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site