lkml.org 
[lkml]   [2017]   [Mar]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[GIT PULL] platform-drivers-x86 for 4.11-2
Hi Linus,

I intended to get this to you earlier. Between the job change (Intel to VMware),
rebuilding my CI machine and moving the office, I didn't get it out as soon as I
would have liked. The changes are all very well contained. The fujitsu cleanup
has been in next and ready for a while and I think is still suitable for RC2 -
but if you disagree, I can resubmit with only the Asus changes which fix a
specific issue with the airplane-mode LED.

The following changes since commit af050abb5c2e5e7d3e1368475d63cbac597dc34f:

platform/x86: intel_turbo_max_3: make it explicitly non-modular (2017-02-24 23:48:54 -0800)

are available in the git repository at:

git://git.infradead.org/linux-platform-drivers-x86.git tags/platform-drivers-x86-v4.11-2

for you to fetch changes up to d1c4e9bf73e739b937ddd9dc4cf0f6de2e6117da:

platform/x86: asus-wmi: Remove quirk_no_rfkill (2017-03-12 16:41:55 -0700)

Thanks,

Darren Hart
VMware Open Source Technology Center

----------------------------------------------------------------
platform-drivers-x86 for v4.11-2

Asus fixes for the airplane LED and a long awaited fujitsu cleanup.

asus-wmi:
- Remove quirk_no_rfkill
- Detect quirk_no_rfkill from the DSDT

fujitsu-laptop:
- remove redundant MODULE_ALIAS entries
- autodetect LCD interface on all models
- simplify acpi_bus_register_driver() error handling
- remove redundant forward declarations
- replace numeric values with constants
- rename FUNC_RFKILL to FUNC_FLAGS
- make platform-related variables match naming convention
- replace "hotkey" with "laptop" in symbol names
- clearly denote backlight-related symbols

----------------------------------------------------------------
Alan Jenkins (9):
platform/x86: fujitsu-laptop: clearly denote backlight-related symbols
platform/x86: fujitsu-laptop: replace "hotkey" with "laptop" in symbol names
platform/x86: fujitsu-laptop: make platform-related variables match naming convention
platform/x86: fujitsu-laptop: rename FUNC_RFKILL to FUNC_FLAGS
platform/x86: fujitsu-laptop: replace numeric values with constants
platform/x86: fujitsu-laptop: remove redundant forward declarations
platform/x86: fujitsu-laptop: simplify acpi_bus_register_driver() error handling
platform/x86: fujitsu-laptop: autodetect LCD interface on all models
platform/x86: fujitsu-laptop: remove redundant MODULE_ALIAS entries

João Paulo Rechi Vita (2):
platform/x86: asus-wmi: Detect quirk_no_rfkill from the DSDT
platform/x86: asus-wmi: Remove quirk_no_rfkill

drivers/platform/x86/asus-nb-wmi.c | 49 +---
drivers/platform/x86/asus-wmi.c | 22 +-
drivers/platform/x86/asus-wmi.h | 1 -
drivers/platform/x86/fujitsu-laptop.c | 451 +++++++++++++++++-----------------
4 files changed, 241 insertions(+), 282 deletions(-)

--
Darren Hart
VMware Open Source Technology Center

\
 
 \ /
  Last update: 2017-03-13 00:58    [W:0.077 / U:0.136 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site