lkml.org 
[lkml]   [2017]   [Oct]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v9 3/5] x86/cpuid: Make clearcpuid an early param

* Andi Kleen <andi@firstfloor.org> wrote:

> From: Andi Kleen <ak@linux.intel.com>
>
> Make clearcpuid= an early param, to make sure it is parsed
> before the XSAVE initialization. This allows to modify
> XSAVE state by clearing specific CPUID bits.
>
> Reviewed-by: Thomas Gleixner <tglx@linutronix.de>
> Signed-off-by: Andi Kleen <ak@linux.intel.com>
> ---
> arch/x86/kernel/cpu/common.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/x86/kernel/cpu/common.c b/arch/x86/kernel/cpu/common.c
> index fd47692e5ce9..ff51c61d2df0 100644
> --- a/arch/x86/kernel/cpu/common.c
> +++ b/arch/x86/kernel/cpu/common.c
> @@ -1310,7 +1310,7 @@ static __init int setup_disablecpuid(char *arg)
>
> return 1;
> }
> -__setup("clearcpuid=", setup_disablecpuid);
> +early_param("clearcpuid", setup_disablecpuid);

Yeah, so there's pre-existing bad naming here that should be fixed before we add
new complexity to the code: why is the option named 'clearcpuid' while the
function name is 'disablecpuid'?

Thanks,

Ingo

\
 
 \ /
  Last update: 2017-10-12 10:10    [W:0.086 / U:9.400 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site