lkml.org 
[lkml]   [2017]   [Oct]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v9 2/5] x86/cpuid: Add generic table for cpuid dependencies
> So instead of adding helpers the 1<< ops can be written out explicitly - they are 
> easy to read after all. Can also be:
>
> var &= ~BIT(bit);
> var |= BIT(bit);

It's some more complicated because "var" are arrays.
Opencoding is fairly ugly.

I changed the main bitmap to use DECLARE_BITMAP now, which
avoids most of the casts. For accessing c->x86_capability and
cpu_caps_cleared it uses helpers now that do implicit casting.

-Andi

\
 
 \ /
  Last update: 2017-10-13 19:47    [W:0.772 / U:0.200 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site