lkml.org 
[lkml]   [2015]   [Feb]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[patch] w1: small cleanup in w1_family_notify()
"sl->family->fops" and "fops" are the same thing, but it's nicer to use
"fops" everywhere.

Signed-off-by: Dan Carpenter <dan.carpenter@oracle.com>

diff --git a/drivers/w1/w1.c b/drivers/w1/w1.c
index 181f41c..59f932f 100644
--- a/drivers/w1/w1.c
+++ b/drivers/w1/w1.c
@@ -649,7 +649,7 @@ static int w1_family_notify(unsigned long action, struct w1_slave *sl)
break;
case BUS_NOTIFY_DEL_DEVICE:
if (fops->remove_slave)
- sl->family->fops->remove_slave(sl);
+ fops->remove_slave(sl);
if (fops->groups)
sysfs_remove_groups(&sl->dev.kobj, fops->groups);
break;

\
 
 \ /
  Last update: 2015-02-20 12:01    [W:0.040 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site