lkml.org 
[lkml]   [2015]   [Oct]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 07/25] x86, pkeys: new page fault error code bit: PF_PK
From
Date
On 10/01/2015 04:54 AM, Thomas Gleixner wrote:
> On Mon, 28 Sep 2015, Dave Hansen wrote:
>> >
>> > /*
>> > @@ -916,7 +918,10 @@ static int spurious_fault_check(unsigned
>> >
>> > if ((error_code & PF_INSTR) && !pte_exec(*pte))
>> > return 0;
>> > -
>> > + /*
>> > + * Note: We do not do lazy flushing on protection key
>> > + * changes, so no spurious fault will ever set PF_PK.
>> > + */
> It might be a bit more clear to have:
>
> /* Comment .... */
> if ((error_code & PF_PK))
> return 1;
>
> return 1;
>
> That way the comment is associated to obviously redundant code, but
> it's easier to read, especially if we add some new PF_ thingy after
> that.

Agreed, that's a nicer way to do it. I'll fix it up.


\
 
 \ /
  Last update: 2015-10-01 19:41    [W:0.321 / U:0.092 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site