lkml.org 
[lkml]   [2013]   [Sep]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[git pull] vfs pile 3/many...
Waiman's conversion of d_path() and bits related to it, kern_path_mountpoint(),
several cleanups and fixes (exportfs one is -stable fodder, IMO). There
definitely will be more... ;-/ Please, pull from the usual place -
git://git.kernel.org/pub/scm/linux/kernel/git/viro/vfs.git for-linus

Shortlog:
Al Viro (8):
afs: get rid of redundant ->d_name.len checks
exportfs: don't assume that ->iterate() won't feed us too long entries
prune_super(): sb->s_op is never NULL
Kill indirect include of file.h from eventfd.h, use fdget() in cgroup.c
take unlazy_walk() into umount_lookup_last()
rename user_path_umountat() to user_path_mountpoint_at()
introduce kern_path_mountpoint()
split read_seqretry_or_unlock(), convert d_walk() to resulting primitives

Ian Kent (1):
autofs4 - fix device ioctl mount lookup

Waiman Long (1):
dcache: Translating dentry into pathname without taking rename_lock

Diffstat:
fs/afs/dir.c | 24 -----
fs/autofs4/dev-ioctl.c | 23 +++---
fs/dcache.c | 220 +++++++++++++++++++++++++++++++----------------
fs/exportfs/expfs.c | 2 +-
fs/internal.h | 3 +
fs/namei.c | 112 +++++++++++++-----------
fs/namespace.c | 2 +-
fs/super.c | 2 +-
include/linux/eventfd.h | 3 +-
include/linux/namei.h | 4 +-
kernel/cgroup.c | 33 ++++----
11 files changed, 241 insertions(+), 187 deletions(-)


\
 
 \ /
  Last update: 2013-09-10 18:41    [W:0.033 / U:2.068 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site