lkml.org 
[lkml]   [2013]   [Jul]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[git pull] more vfs.git stuff

O_TMPFILE ABI changes, Oleg's fput() series, misc cleanups,
including making simple_lookup() usable for filesystems with non-NULL,
which allows to get rid of quite a bit of ugliness. Please, pull from
git://git.kernel.org/pub/scm/linux/kernel/git/viro/vfs.git for-linus

Shortlog:
Al Viro (8):
Safer ABI for O_TMPFILE
rpc_create_*_dir: don't bother with qstr
__rpc_lookup_create_exclusive: pass string instead of qstr
configfs: don't open-code d_alloc_name()
make simple_lookup() usable for filesystems that set ->s_d_op
efivarfs: we can use simple_lookup() now
cgroup: we can use simple_lookup() now
sunrpc: now we can just set ->s_d_op

Andrew Morton (1):
fs/file_table.c:fput(): add comment

Oleg Nesterov (3):
fput: turn "list_head delayed_fput_list" into llist_head
llist: fix/simplify llist_add() and llist_add_batch()
llist: llist_add() can use llist_add_batch()

Diffstat:
arch/alpha/include/uapi/asm/fcntl.h | 2 +-
arch/parisc/include/uapi/asm/fcntl.h | 2 +-
arch/sparc/include/uapi/asm/fcntl.h | 2 +-
fs/configfs/dir.c | 13 +--------
fs/efivarfs/inode.c | 14 +----------
fs/file_table.c | 31 ++++++++++++-----------
fs/libfs.c | 3 +-
fs/namei.c | 2 +-
fs/open.c | 4 +-
include/linux/fs.h | 2 +
include/linux/llist.h | 19 +++-----------
include/linux/sunrpc/rpc_pipe_fs.h | 4 +-
include/uapi/asm-generic/fcntl.h | 8 ++++-
kernel/cgroup.c | 11 +-------
lib/llist.c | 15 ++++-------
net/sunrpc/cache.c | 18 ++++----------
net/sunrpc/clnt.c | 20 ++++++---------
net/sunrpc/rpc_pipe.c | 45 +++++++++++----------------------
18 files changed, 75 insertions(+), 140 deletions(-)


\
 
 \ /
  Last update: 2013-07-14 19:41    [W:0.032 / U:0.476 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site