[lkml]   [2012]   [Aug]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [dm-devel] [PATCH] dm: verity support data device offset (Linux 3.4.7)
    On 08/08/2012 08:46 PM, Mikulas Patocka wrote:

    > The problem with the patch is that it changes interface to the userspace
    > tool. The userspace tool veritysetup already exists in recent cryptsetup
    > package, so we can't change the interface - you should change the patch so
    > that the starting data block is the last argument and the argument is
    > optional - so that it is compatible with the existing userspace too.

    yes. Please never change interface without at least increasing target version.

    I have to add userspace support as well to veritysetup and we need a way
    how to detect that option is supported by running kernel.


     \ /
      Last update: 2012-08-08 23:21    [W:0.024 / U:0.132 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site