lkml.org 
[lkml]   [2009]   [Aug]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] PM: Add convenience macro to make switching to dev_pm_ops less error-prone
On Wed, Aug 05, 2009 at 11:30:07PM +0200, Rafael J. Wysocki wrote:
> On Wednesday 05 August 2009, Frans Pop wrote:
> > Rafael J. Wysocki wrote:
> >
> > > +#define SIMPLE_DEV_PM_OPS(name, suspend_fn, resume_fn) \
> > > +struct dev_pm_ops name = { \
> > > + .suspend = suspend_fn, \
> > > + .resume = resume_fn, \
> > > + .freeze = suspend_fn, \
> > > + .thaw = resume_fn, \
> > > + .poweroff = suspend_fn, \
> > > + .resume = resume_fn, \
> >
> > That defines .resume twice. Guess the last should be restore.
>
> Yes, thanks to you and Philipp for noticing that and sorry for the mistake.

When is a good point to resend patches that use this macro? I guess they
won't make it to .31 anyway, right? So I just wait for the next merge
window?

Daniel



\
 
 \ /
  Last update: 2009-08-06 10:55    [W:0.160 / U:0.116 seconds]
©2003-2011 Jasper Spaans. Advertise on this site