lkml.org 
[lkml]   [2009]   [Apr]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[PATCH] splice: fix new kernel-doc warnings
From: Randy Dunlap <randy.dunlap@oracle.com>

splice: fix kernel-doc warnings

Warning(fs/splice.c:617): bad line:
Warning(fs/splice.c:722): No description found for parameter 'sd'
Warning(fs/splice.c:722): Excess function parameter 'pipe' description in 'splice_from_pipe_begin'

Signed-off-by: Randy Dunlap <randy.dunlap@oracle.com>
---
fs/splice.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

--- linux-2.6.30-rc2-git1.orig/fs/splice.c
+++ linux-2.6.30-rc2-git1/fs/splice.c
@@ -614,7 +614,6 @@ static void wakeup_pipe_writers(struct p
* @actor: handler that splices the data
*
* Description:
-
* This function loops over the pipe and calls @actor to do the
* actual moving of a single struct pipe_buffer to the desired
* destination. It returns when there's no more buffers left in
@@ -711,7 +710,7 @@ EXPORT_SYMBOL(splice_from_pipe_next);

/**
* splice_from_pipe_begin - start splicing from pipe
- * @pipe: pipe to splice from
+ * @sd: information about the splice operation
*
* Description:
* This function should be called before a loop containing

\
 
 \ /
  Last update: 2009-04-17 04:45    [W:0.037 / U:0.208 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site