lkml.org 
[lkml]   [2007]   [Jun]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Subject[BUG] libata IT821X driver still fails! Hard-freezes system.
    From
    Date
    This is the screen image I took with my digital camera when bootup
    freezes:
    http://spherevision.org/sync/visual/itefreeze.jpg

    After this freeze, not even SysRq commands work.
    On a side-note, the non-libata drivers boot up, but throw tons of DMA
    errors after one DVD burn.

    The kernel I tested this on (newest I would try) is 2.6.22-rc4 with and
    without cfs16. I am willing to test out patches if I can get this darn
    controller working.

    My config: http://spherevision.org/sync/tmp/dot.config

    At the time of this freeze, the kernel was not tainted. I am running a
    Pentium-D 830 3.0GHz Dualcore on a ASUS P5LD2 with latest bios rev.
    1804.

    My lspci -vvv info: http://spherevision.org/sync/tmp/lspci.out

    I also find it pecular that it says there is a 40wire cable; I have
    tried 3 different 80wire cables and it doesn't make a difference. So,
    yes indeed I am using proper cables, and have tried others.

    Just to make sure, this a brand new 20A1P burner, the old one did the
    same thing though.

    If I build pata_821x(or whatnot) as a module, system freezes after about
    5 seconds after insmod, without dumping any information at all.

    It may say it's a RAID controller, but on this motherboard it seems to
    be pure passthru because there is no RAID option for this controller in
    the BIOS. I have also tried a few flags recommended by Alan before,
    which do not help.

    Help would be very much appreciated! Further info, if needed, just ask.

    -r








    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2007-06-14 10:45    [W:0.021 / U:60.920 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site