lkml.org 
[lkml]   [2006]   [Apr]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.6.16.2 -> 2.6.16.9 smp apic network problems
This is kind of an odd situation and I'm thoroughly confused as to why
things don't work.

I have a router/file server/web server, dual p3 board with two nics
one using the tulip and the other using 8139too driver.

For as long as I can remember I've had to put noapic on the kernel
cmdline to get network to work. Something having to due with local
apic and apic being automatically selected when enabling smp. With
apic I don't have any network, dhcpcd doesn't work I can assign static
ip's and static routes but can't ping anything no trafic in or out.

I tried removing the noapic lines all together and it won't even
register the network device (ie modprobes just fine but ifconfig -a
doesn't show a new network device).

And now when I upgraded the kernel to 2.6.16.9 from 16.2 I'm getting
the same results as without passing noapic to the kernel. I have no
network connectivity with these later releases of the stable kernel.
Any suggestions as to why this is happening and what I can do to
update my kernel and make things work would be helpful. I've tried
passing noapic and nolapic but the kernel apparently doesn't recognize
nolapic (documentation fix there).

When I remove smp I have the options to remove apic and local apic and
things work fine with one processor. However I really don't want to be
stuck using one processor on a dual processor system for the rest of
it's days.

I'm still not getting it to work even with 2.6.16.11 has the same
results I already sent this to kernelnewbies but no one responded
really so I'm sending it to lkml.

- David Brown
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-04-25 18:46    [from the cache]
©2003-2011 Jasper Spaans