lkml.org 
[lkml]   [2005]   [Sep]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] use kzalloc instead of malloc+memset
Dmitry Torokhov <dtor_core@ameritech.net> wrote:
>
> On Monday 12 September 2005 23:43, Pekka Enberg wrote:
> > On 9/13/05, Jiri Slaby <jirislaby@gmail.com> wrote:
> > > >- cls = kmalloc(sizeof(struct class), GFP_KERNEL);
> > > >+ cls = kzalloc(sizeof(struct class), GFP_KERNEL);
> > > >
> > > >
> > > maybe, the better way is to write `*cls' instead of `struct class',
> > > better for further changes
> >
> > Please note that some maintainers don't like it. I at least could not
> > sneak in patches like these to drivers/usb/ because I had changed
> > sizeof.
> >
>
> And given the fact that Greg maintains driver core it probably won't be
> accepted here either :)
>
> FWIW I also prefer spelling out the structure I am allocating.
>

It hurts readability. Quick question: is this code correct?

dev = kmalloc(sizeof(struct net_device), GFP_KERNEL);

you don't know. You have to go hunting down the declaration of `dev' to
find out.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-09-13 08:45    [W:4.424 / U:0.004 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site