[lkml]   [2003]   [Sep]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] oops_in_progress is unlikely()

> > > none of this patch seems to touch particularly performance critical code.
> > > Is it really worth adding these macros to every if statement in the kernel?
> > > There comes a point where readability is lost, for no measurable gain.
> >
> > Perhaps we should have macros ifu() and ifl(), that would be used as a
> > plain if, just with likelyness-indication? That way we could have it
> > in *every* statement and readability would not suffer that much...
> You've got to be kidding.

I'm pretty serious.

ifu (a==b) {

looks better than

if (unlikely(a==b)) {

sched.c alone probably would get more readable as a result of such

[Okay, having it at every statement is prbably bad idea.]
When do you have a heart between your knees?
[Johanka's followup: and *two* hearts?]
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:48    [W:0.063 / U:0.116 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site