lkml.org 
[lkml]   [2003]   [Apr]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject3ware 7500 RAID problems....
Date
I recently upgraded to RedHat 9.0 only to find that my 600GB RAID system no
longer works. It worked fine with RH 8.0, however once I upgraded, it no
longer came up cleanly and I got lots of error messages during boot.

I contacted RedHat and they said to try a fresh install, which I did-and got
the same thing. Currently I am running RH 9.0 with the 2.4.20-9 kernel.
I read through the list archives regarding other's problems with 3ware, and
while at first it sounded like the same problems I am having, when I went to
the Western Digital site to download the firmware (as suggested in the
post), I found that it was only for 180GB and 200GB drives. All my drives
in my RAID array are 120GB.

The western digital firmware upgrade page is here:
http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_admin=1&p_
faqid=913&p_created=1047068027

The kernel thread I am referring to is here:
http://marc.theaimsgroup.com/?l=linux-kernel&m=104854143005751&w=2

Any ideas? My system worked fine with RH8 and there have been no hardware
changes. I checked the ARRAY's integrity with the 3ware tools and it
reported ok.

Here's a snipit of my boot log regarding the 3ware controller (there should
be only one big partition (sda1)

--cut-
VFS: Mounted root (ext2 filesystem).
SCSI subsystem driver Revision: 1.00
3ware Storage Controller device driver for Linux v1.02.00.031.
PCI: Found IRQ 15 for device 02:01.0
scsi0 : Found a 3ware Storage Controller at 0xa000, IRQ: 15, P-chip: 1.3
scsi0 : 3ware Storage Controller
blk: queue c366a614, I/O limit 4095Mb (mask 0xffffffff)
Vendor: 3ware Model: 3w-xxxx Rev: 1.0
Type: Direct-Access ANSI SCSI revision: 00
blk: queue c366a814, I/O limit 4095Mb (mask 0xffffffff)
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sda: 1172197760 512-byte hdwr sectors (600165 MB)
sda: sda1 sda2 sda4
Journalled Block Device driver loaded
3w-xxxx: scsi0: Command failed: status = 0xc1, flags = 0x11, unit #0.
3w-xxxx: scsi0: AEN: ERROR: Drive error: Port #0.
3w-xxxx: scsi0: Reset succeeded.
3w-xxxx: scsi0: Command failed: status = 0xc1, flags = 0x11, unit #0.
scsi: device set offline - not ready or command retry failed after host
reset: host 0 channel 0 id 0 lun 0
3w-xxxx: scsi0: AEN: ERROR: Drive error: Port #0.
SCSI disk error : host 0 channel 0 id 0 lun 0 return code = 2
I/O error: dev 08:01, sector 0
I/O error: dev 08:01, sector 2
I/O error: dev 08:01, sector 0
--cut-
I have A LOT of stuff on there I need to get to, if anyone has any advice on
how to get it working again, please let me know. I did try to go back to
RH8, but it just sat there after I select "no I don't want to initialize
/sda1 and destroy all data).

Thanks.



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:35    [from the cache]
©2003-2011 Jasper Spaans