lkml.org 
[lkml]   [2002]   [Apr]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: RAID superblock confusion
Andreas Dilger writes:
> On Apr 10, 2002 13:24 -0600, Richard Gooch wrote:
> > Andreas Dilger writes:
> > > On Apr 10, 2002 09:33 -0600, Richard Gooch wrote:
> > > > Even though I'm using persistent superblockss, which is supposed to
> > > > allow one to move devices from one controller to another, I can't
> > > > use my RAID) set in this configuration. Looks like a bug.
> > > >
> > > > md0: former device scsi/host2/bus0/target1/lun0/part2 is unavailable,
> > > > removing from array!
> > > > md: md0, array needs 6 disks, has 5, aborting.
> > >
> > > Note that this appears to be your real problem.
> >
> > No. I tested all 6 partitions used in the RAID set. They are all
> > available.
>
> Well, MD seems to think it is unavailable... I would check the
> codepath that generates this message and see why it is happening.
> Maybe it is a timing issue or something, that MD autostart is
> starting before this device is set up or something? I don't know.

The device is set up (i.e. SCSI host driver is loaded) long before I
do raidstart /dev/md/0

Regards,

Richard....
Permanent: rgooch@atnf.csiro.au
Current: rgooch@ras.ucalgary.ca
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:25    [W:0.073 / U:0.068 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site