[lkml]   [2001]   [Feb]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectHow to set hdparms for ide-scsi devices on devfs?
Sorry, if this issue was already discussed in lkml. I didn't find
a reference to this at

My Problem:
I want to set the unmaskirq and dma -flag for my ide cd-recorder.
The Problem is, that devfs creates no ide device, but only
the /dev/scsi/../{cd,general} devices are created. And hdparm
don't accepts this devices for setting the ide-parameters.

My current workaround is to create a /dev/hd? device "by hand"
at system startup. This is not very beautiful. Furthermore, if
the device numbers in devfs are deactivated, this won't work

I can live with my current solution. But i would be very happy
if someone can present a clean solution.

I posted this message intentionally not on the devfs mailing list
as i think this problem is related to accessing the same device
through different /dev entries. Under devfs, the /dev/ide/...
device node gets allocated after the corresponding ide-xx.o has
been loaded. But this is not possible with ide-scsi claiming
the device :(

Thanks in advance

Eduard Hasenleithner
student of
Salzburg University of Applied Sciences and Technologies
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:28    [W:0.064 / U:0.768 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site