Messages in this thread |  | | From | Miguel Ojeda <> | | Date | Fri, 27 Mar 2026 11:11:04 +0100 | | Subject | Re: [PATCH 3/8] rust: io: use pointer types instead of address |
| |
On Thu, Mar 26, 2026 at 3:35 PM Gary Guo <gary@garyguo.net> wrote: > > This is a `*mut T` -> `*const c_void` cast which needs > `cast_const().cast::<c_void>` which I think is less readable than just `as`. > > It's also existing code that I haven't touched in this commit.
I agree it is usually best to change it independently.
In any case, regarding the suggestion, the latter form is more restricted, which is what we wanted when we enabled the Clippy lints, no? Cc'ing Tamir.
I agree it is definitely less readable when one is not accustomed to the `cast` methods (e.g. which one is supposed to be used for what etc.), i.e. `as` is just obvious. On the other hand, it also makes more explicit that we are doing a "bigger jump", i.e. both const and type, which is why `as` is "worse" in that it allows for more things to happen at once.
Cheers, Miguel
|  |