lkml.org 
[lkml]   [2026]   [Mar]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v3 3/6] of_reserved_mem: add a helper for rmem device_init op
On Sat, Mar 14, 2026 at 12:06 AM Rob Herring <robh@kernel.org> wrote:
>
> On Fri, Mar 06, 2026 at 11:36:34AM +0100, Albert Esteve wrote:
> > Add a helper function wrapping internal reserved memory
> > device_init call and expose it externally.
>
> Why?
>
> The diff tells us what. The commit msg needs to tell us why. Maybe the
> rest of the series explains it, but this commit needs to stand on its
> own.

ACK.

This patch prepares for the heap implementation in patch #4, which
uses the new helper function. I will add the information to the commit
body.

>
> >
> > Use the new helper function within of_reserved_mem_device_init_by_idx().
> >
> > Signed-off-by: Albert Esteve <aesteve@redhat.com>
> > ---
>
> Version history?

You mean track it in the commit body? History is already detailed in
the cover letter.

>
> > drivers/of/of_reserved_mem.c | 68 ++++++++++++++++++++++++++---------------
> > include/linux/of_reserved_mem.h | 8 +++++
> > 2 files changed, 52 insertions(+), 24 deletions(-)
>


\
 
 \ /
  Last update: 2026-03-16 12:00    [from the cache]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and my Meterkast|Read the blog