lkml.org 
[lkml]   [2024]   [May]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 08/17] Add main.c
Date
"Nemanov, Michael" <michael.nemanov@ti.com> writes:

> On 5/22/2024 12:46 PM, Krzysztof Kozlowski wrote:
>> ... > +} > + > +static int read_version_info(struct cc33xx *cc) > +{
>> > + int ret; > + > + cc33xx_info("Wireless driver version %s",
>> DRV_VERSION); Drop > + > + ret =
>> cc33xx_acx_init_get_fw_versions(cc); > + if (ret < 0) { > +
>> cc33xx_error("Get FW version FAILED!"); > + return ret; > + } > + >
>> + cc33xx_info("Wireless firmware version %u.%u.%u.%u", > +
>> cc->all_versions.fw_ver->major_version, > +
>> cc->all_versions.fw_ver->minor_version, > +
>> cc->all_versions.fw_ver->api_version, > +
>> cc->all_versions.fw_ver->build_version); > + > +
>> cc33xx_info("Wireless PHY version %u.%u.%u.%u.%u.%u", > +
>> cc->all_versions.fw_ver->phy_version[5], > +
>> cc->all_versions.fw_ver->phy_version[4], > +
>> cc->all_versions.fw_ver->phy_version[3], > +
>> cc->all_versions.fw_ver->phy_version[2], > +
>> cc->all_versions.fw_ver->phy_version[1], > +
>> cc->all_versions.fw_ver->phy_version[0]); > + > +
>> cc->all_versions.driver_ver = DRV_VERSION; Drop
>
> You mean drop the trace? Will exposing FW/PHY versions via debugfs be
> OK?

I'm guessing the comment was about DRV_VERSION. We don't use any version
strings for drivers as they are useless.

BTW please check your quoting style, it is hard to read your replies.

--
https://patchwork.kernel.org/project/linux-wireless/list/

https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches

\
 
 \ /
  Last update: 2024-05-30 16:38    [W:7.449 / U:0.012 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site