lkml.org 
[lkml]   [2024]   [May]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [RFC PATCH v2 5/8] ACPI: APEI: EINJ: Add einjv2 extension struct
From
On 5/21/24 4:10 PM, Zaid Alali wrote:
> Add einjv2 extension struct and EINJv2 error types to prepare
> the driver for EINJv2 support. ACPI specifications(1) enables
> EINJv2 by extending set_error_type_with_address strcut.
>
> Signed-off-by: Zaid Alali <zaidal@os.amperecomputing.com>
> ---
> drivers/acpi/apei/einj-core.c | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)
>
> diff --git a/drivers/acpi/apei/einj-core.c b/drivers/acpi/apei/einj-core.c
> index cc5ad1f45ea4..2021bea02996 100644
> --- a/drivers/acpi/apei/einj-core.c
> +++ b/drivers/acpi/apei/einj-core.c
> @@ -50,6 +50,28 @@
> */
> static int acpi5;
>
> +struct syndrome_array {
> + union {
> + u32 acpi_id;
> + u32 device_id;
> + u32 pcie_sbdf;
> + u8 fru_id[16];

I would rename fru_id to vendor_id since this isn't necessarily a FRU id. It also has the
added benefit of matching the naming of the vendor field in comp_synd as well.

> + } comp_id;
> + union {
> + u32 proc_synd;
> + u32 mem_synd;
> + u32 pcie_synd;
> + u8 vendor_synd[16];
> + } comp_synd;
> +};
> +
> +struct einjv2_extension_struct {
> + u32 length;
> + u16 revision;
> + u16 component_arr_count;
> + struct syndrome_array component_arr[];
> +};
> +
> struct set_error_type_with_address {
> u32 type;
> u32 vendor_extension;
> @@ -58,6 +80,7 @@ struct set_error_type_with_address {
> u64 memory_address;
> u64 memory_address_range;
> u32 pcie_sbdf;
> + struct einjv2_extension_struct einjv2_struct;
> };
> enum {
> SETWA_FLAGS_APICID = 1,

\
 
 \ /
  Last update: 2024-05-22 18:51    [W:0.057 / U:0.396 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site